Zxr400k TCI on a Gsf400 Bandit

Moderator: Moderators

Post Reply
Zest12
Posts: 5
Joined: Wed Oct 13, 2021 8:53 am
My Bike: Zxr

Zxr400k TCI on a Gsf400 Bandit

Post by Zest12 »

Hello, so I'm trying to revive a Suzuki gsf400 bandit that has its TCI missing. Previous guy had it fixed by having 2 chinese 150cc cdi's feeding each coil. Bike ran but quiet crappy and under powered

Considering this engine has the same single pickup coil system as does the zzr and zxr, im trying to put one of my spare zxr400k tci's onto this engine

The wiring diagram by @banner001 and another diagram i found online are quiet different and confusing for me to go ahead with making connections. Any help regarding this will be of great help

Attaching the pictures of the circuit board I have and the diagrams I am looking at
You do not have the required permissions to view the files attached to this post.
User avatar
banner001
Track day God
Track day God
Posts: 2555
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Zxr400k TCI on a Gsf400 Bandit

Post by banner001 »

Hi there, so the zxr cdi only requires a few wires (assuming it's an M cdi...)

You need 2 wires going to the pickup coil (these are the black/white and yellow wires)

You need to power both coil packs (red wire, not part of the cdi), and you wire both coil packs to the cdi (black and green wires)

The cdi needs power and ground (brown wire, and black/yellow wire)

You need a switched 9v down the anti tamper wire (grey), this is achieved using the resistor in the picture.

You also need to either wire in all of the starter lockout mechanisms, or ground the green/black wire

If you have a cdi with a speed limiter, then you need to wire the pink to ground via a different resistor.

I don't have the cdi pinouts to their wires...but I'm sure someone can provide them to you.
UK ZXR400 L3 (1993) - Fully restored and on the roads, my green beast!
JPN ZXR250 A2 (1990) - Revs to 19,200rpm... 'nuff said :smt003
Zest12
Posts: 5
Joined: Wed Oct 13, 2021 8:53 am
My Bike: Zxr

Re: Zxr400k TCI on a Gsf400 Bandit

Post by Zest12 »

Thankyou so much for your reply!

I get much of what you have explained. The Tci I have however does not has its connector and thus no wires indicating colors. I will be making a custom connector myself

So there are 6 pins. 5 are used 1 pin is not. I just need to figure out that 1 pin

Also when you say the red wire is not part of the cdi/tci, but lookinh at the diagram indicates a live red battery+ wire going into the cdi and plug coils

Thanks again!
Zest12
Posts: 5
Joined: Wed Oct 13, 2021 8:53 am
My Bike: Zxr

Re: Zxr400k TCI on a Gsf400 Bandit

Post by Zest12 »

I have a feeling if I feed 1 wrong pin with the wrong wire I will have a burnt cdi. And its worth a pretty penny from where I'm from

As for resistors, 1 end of the resistor connected to red wire and the 2nd end into the cdi

Same for the resistor on earth/ground inti cdi?
User avatar
banner001
Track day God
Track day God
Posts: 2555
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Zxr400k TCI on a Gsf400 Bandit

Post by banner001 »

So you will be using either 8 or 9 pins on the cdi depending if you need the pink wire or not.

I am using my diagram for the wire colours, not the other one you found, so on mine (which is the original OEM wire colours), the red wire only goes from kill switch to the 2 coils.

I doubt I will remember, but if I do I will get you the pinouts for the cdi on my 1993 bike
UK ZXR400 L3 (1993) - Fully restored and on the roads, my green beast!
JPN ZXR250 A2 (1990) - Revs to 19,200rpm... 'nuff said :smt003
Ewetea
zxr400 oc member
zxr400 oc member
Posts: 147
Joined: Mon Jan 12, 2009 12:04 pm
My Bike: ZXR400L5
Location: Newport Shropshire

Re: Zxr400k TCI on a Gsf400 Bandit

Post by Ewetea »

The coloured wires are connected to the M CDI on my 1991 ZXR400 L1 as follows:
Six pin connector on the left hand side: top row= 1.Green 2.blank 3.Brown. Bottom row = 4.Black 5.Green/Black 6.Black/White
Four pin connector on the right hand side: top row= 7.blank 8.Black/White. Bottom row = 9.Grey 10.Yellow
Zest12
Posts: 5
Joined: Wed Oct 13, 2021 8:53 am
My Bike: Zxr

Re: Zxr400k TCI on a Gsf400 Bandit

Post by Zest12 »

So I did manage to find a picture of the CDI connector. The 3rd pin on the 6 pin connector is unused

Do I have to wire 2 resistors or just 1 100ohm resistor will do?

Thankyou all for your help!
You do not have the required permissions to view the files attached to this post.
Post Reply